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What is Load Scheduling Assignment (LSA)? 
 

LSA is a process that will assign tasks to qualified Technicians or Teams. DLCPM uses a genetic 
algorithm to create an optimal schedule, which incorporates predefined technician availability, 
proficiency, lab hours, case due date, and other criteria. This algorithm uses a term known as 
“depth levels”, which can be seen as the number of iterations (or revisions) that the system will 
perform. This can range from 1 to 10 – with the optimal amount of iterations being 3.  

In essence, more depth levels are the equivalent of more revisions. Therefore, more levels 
require a longer process time. 

There are a number of requirements for LSA to be most effective. Listed below are the most 
critical steps that must be set up in DLCPM before utilizing the LSA feature: 

 Task 
 Ship Date 
 Due Date 
 Task Duration 
 Number of units that can be produced in a work day 
 Task Proficiency level 
 Team Assignment 
 Customer technician preference, if applicable  
 Technician availability  
 Business hours 
 Technician Hours 
 Equipment Setup, if certain Equipment should be included as part of LSA (For example: 

Milling Machine) 
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Load Scheduling Assignment Setup 
Prerequisites 

In addition to the setup required to run the Load Scheduling Assignment, it is important that the proper 
prerequisites are configured. There are case schedule options and Global Settings to configure 
production tasks, product schedules.  

In the Case Scheduling tab of the Case Options under Global Settings, select the option for ‘Enable case 
scheduling’ and configure the appropriate settings. 

In the Products & Tasks Lists under Global Settings, the Production Tasks is the area where the master 
list or library of tasks is defined. Once the master list of tasks is defined, each individual product 
schedule must be defined under the Product Tasks tab of the Products maintenance.  

In the Case Statuses section of the Global Settings, there is a new checkbox option that must be checked 
on any Case Status your lab will need Load Scheduling to consider. This will ensure that Load Scheduling 
will schedule tasks from cases that have a status marked ‘For Load Schedule’.  

 

*Please note: when the MTS Support Team upgrades your installation, the option for Load Schedule 
will automatically mark In Production status for Load Schedule.  

 

All of these areas must be configured in order for tasks to schedule on cases that are entered.  
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Global Settings 

(File > Global Settings > Case Options > Load Schedule) 

Under the Global settings, users must review this default checkbox option. If this option is enabled, 
when a user configures the Load Scheduling for Production Tasks, the task duration used for case 
scheduling will reset to the duration configured for Load Schedule Configuration.  

For most tasks the duration for case scheduling and Load Scheduling may stay the same but this option 
provides backwards compatibility.  
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Equipment  

(File > Global Settings > Laboratory Lists)  

When a task list is defined for equipment, it is actually defined for the equipment type.  An example 
equipment type might be a Milling Machine. 
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Equipment Types – Define the types of equipment that will be used in the production process. 

 

 

 

 

 

 

 

 

 

 

Equipment - Here you will list the equipment used in your lab.  View, add, or edit Tasks that are 
performed using the equipment and define the technicians that are able to use the equipment. 

 

 

There is also an option where users may select to import equipment that has already been defined 
under the Damas Maintenance. 
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When this option is selected, the Import DAMAS Equipment form will populate with all of the existing 
equipment and in order to import the highlighted equipment the lab, department and type must be set 
as well.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Out of Order Reasons – Define the out of order reasons, such as Broken or Maintenance. 
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Lab Hours  

(File > Global Settings > Laboratory Lists > Labs > Edit > Business Hours) 

The laboratory “Business Hours” must be properly set in Lab Settings according to your laboratory’s 
hours. It is necessary also to add the Lunch Break hours in addition to the business hours. 

 

*Please note the following regarding the Business hours:  

If your laboratory hours are 24 hours per day, the Open and Close time should be set Midnight to 
Midnight.  

If there is a conflict between the Open and Close time, scheduling will automatically assume the Open 
and Close times as 8:00 AM to 5:00 PM. An example of a conflict is the Open time is set to 9:00 AM 
and Close is set to 8:00 AM and as a result will automatically change to 8:00 AM to 5:00 PM.   
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Teams  

(File > Global Settings > Laboratory Lists > Teams) 

This module is used for defining your technician teams. Once a team has been added into the 
maintenance list, you can then define all of the technicians in the team and also the tasks that the team 
is capable of performing. 
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Production Tasks  

(File > Products & Tasks Lists > Production Tasks) 

With LSA, you now have the ability to define a number of task units that can be performed within a 
business day.  Additionally, you have the ability to mark the task as being performed by specific 
equipment. The selection for one-unit load duration is the duration required for the task, this is the 
same functionality in previous versions for setting the duration to either Hours or Minutes. 

 

 



 

Load Scheduling Assignment 
http://MagicTouchSoftware.com 

Also located in the Load Schedule Configuration section is a checkbox option for ‘Set Task Duration to LS 
Duration’. When enabled, the task duration is calculated using the Load Schedule duration.  

Please note: when the checkbox option located in the Load Schedule tab of the Global Settings is 
enabled, this is set for each task by default but users have the ability to change this option for each 
task.  
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Production Task Capacity  
Under the Load Schedule Configuration section, the alternative option to the One Unit Load Duration 
configuration is to set the Production Task Capacity.  

 

When this option is selected, the maximum number of units that can be completed in an 8-hour day 
must be defined. This will ensure that certain tasks are not scheduled beyond the laboratory’s capacity.   
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When configuring the Product schedules under the Products maintenance, you are able to configure 
each task within the schedule to assign to a Team or a Technician or Equipment. You may also set a 
required proficiency selecting from the available range from 1 to 5 - with 5, being the highest proficiency 
rating.  

 
The proficiency affects how LSA will assign tasks per technician, team or equipment availability. 
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Employees  

(Employees (top toolbar) > Employees) 

 Technician Capacity  
On the Tasks tab of the Employees form it is important that tasks are assigned to each technician. In 
addition to assigning the tasks, a custom duration can be set in order to configure for a Technician’s 
daily capacity.  

 

In the Custom Duration section, a maximum number of units per 8-hour day can be configured. The 
alternative option that can be set is the option for One Unit Load Duration which follows the basic task 
duration of hours or minutes.  

If there are any Technicians that should be allowed to complete certain tasks, but you would prefer LSA 
not to automatically assign those tasks to technicians, you may mark the option for ‘Exclude from Load 
Schedule’. This will ensure that the technician can manually have a task assignment and complete a task, 
but Load Scheduling will not automatically assign that task.  

Please note: If a technician does not complete all assigned tasks, the incomplete tasks are added to 
his/her capacity for the next working day.   
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Working Hours & Out of Office 
The Working Hours and Out of Office periods will need to be configured for each employee marked as a 
Technician.  LSA will use the option configured here to determine if a technician is able to work during 
certain periods of time.   

Please Note: The reasons maintenance to Out of Office can be defined in the following area of global 
settings – Global Settings > Laboratory Lists > Out of Office Reasons 

 

When configuring the Working Hours, you may set technician hours to match the set Lab Business hours 
or you can create a unique schedule for that individual technician. If there are no hours defined, the lab 
hours will be used.  

Please note: A technician’s custom working hours will supersede the lab business hours. 
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Customer Settings  

(Customers > Customer Settings > Technician Preferences) 

Under the customer settings, you are able to define a customer’s preferred technician to complete 
certain tasks for all products or individual products.   

Please Note: Setting a preferred technician does not guarantee that the technician will be assigned 
these tasks.  A number of factors are considered when the task schedule is determined, such as working 
or unavailable hours defined for that technician, proficiency level and that technician’s current 
assignment. 

 

Practice Doctor Technician Preferences 
If there are multiple practice doctors on one main customer records, users are able to configure 
preferred technicians that are Practice Doctor specific. In order to configure doctor specific preferred 
technicians, select from the drop down menu for Practice Doctor.  

Any technician preferences configured under the selection for – DEFAULT – will apply to all practice 
doctors.  
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Manual (Custom) Assignment Changes 

If there are manual or custom changes made to the assignment of tasks or rescheduling on a case, users 
may select to make sure the Load Scheduling Assignment job does not overwrite these changes.  

On a case, when selecting to edit an individual task, there is a checkbox option for ‘Do not allow 
automatic reassign’.   

 

With this option activated and saved on a task, any changes made will be preserved the next time the 
Load Schedule Assignments job will run.  

Since the Load Schedule Dashboard provides a custom view on task assignments, it is most optimal to 
use to make any custom changes.   
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Automated Services  

(Automated Services (left sidebar) > Job Management > Load Schedule Assignments) 

The Load Schedule Assignments job provides adaptive scheduling for case tasks. It takes multiple factors 
into account and makes an intelligent schedule. This schedule is based off of case tasks, ship date, and 
due date. It then correlates this with technician availability, work hours, skill level, and customer 
preferences.  

The tab for SQL Script tab contains text in code which controls certain functionalities with LSA. It is 
important to consult MTS Support Team prior to making any changes to the code on this tab.  

 

*Please note: Once the tasks are assigned to a technician, they are locked and will never be taken 
away from them unless the special parameter in JP is used to clear the transaction. 
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The schedule tab is where you will need to define the schedule for this job which will control the 
frequency. You may also define if the job should run on weekends, or holidays as well as set a start date 
& time.  
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Load Schedule Dashboard  

(Schedule Dashboard (left sidebar) 

The Schedule View page shows cases that are In Production. You can select a case to view its schedule, 
manually re-schedule a case’s tasks, or even schedule selected cases for the first time.  
 
This form also gives an overview of currently assigned tasks, and gives you the option to view the 
schedule by Technician, Equipment, or Teams. Lastly, the 6th tab displays all tasks that are unassigned. 
From this tab, you are able to edit any unassigned tasks and set assignments accordingly.  

This option will also allow users to view the Technicians, Tasks, Equipment, and Teams. The “Unassigned 
Tasks” page will display the Tasks that system could not assign, which means the lab is over capacity 
based on the current configuration. 
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Load Schedule View  

(Tools > Load Schedule View) 

Under the tools menu, there is an option for Load Schedule View. This is a non-graphical version of the 
Load Schedule Dashboard. This interface would allow users to: 
 

1. Load Schedule is used to perform the following actions: Reschedule a Case, open a Case, Go to 
Customer Record. Edit or Delete a task within the case’s task schedule, Schedule tasks to 
appropriate technicians, Reassign tasks.  

a. Tasks that display with a red box are incomplete and the due date has passed  
b. Tasks that display with a green box were completed on or before the task due date 
c. Tasks that display with a yellow box were completed after the task due date (late) 
d. Tasks that display without color have a task due date that is in the future 
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2. Technicians is used to view your Active technicians and their current Workload.  Additionally, 
technicians’ unavailable periods may be viewed and edited here. 

3. Equipment lists the equipment currently used within the lab and the current work load for that 
piece of equipment.  Additionally, an equipment’s availability can be viewed or edited here. 

4. Teams is used to view the lab’s currently configured teams, along with the team’s 2workload for 
the next 14 days. 

5. Unassigned Tasks gives a complete view of all unassigned tasks in the lab.  The task can also be 
edited from this tab. 

6. Incomplete Tasks displays all tasks that have been assigned but have not yet been completed. 
From this tab users are able to make changes to the task. 

a. Tasks that display with a red box are tasks that are late  
b. Tasks that display with a green box are tasks that are due today or in the future 
c. Tasks that display with a yellow box indicate that the case Ship Date and Ship Time are 

due on the current day’s date, within the current hour 
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Load Scheduling Reports 

Under the Reports menu at the top of the toolbar is an option for Report Monitor. There is a new report 
located that can be projected on a TV or Computer screen.  
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This report is also located in the Report Center under the folder for Laboratory Dashboard and the folder 
for Load Schedule.  
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If users would like to take a look at the tasks assigned to All or an individual technician, there is a report 
located in the Load Schedule folder of the Reports Center called Technician Assignments. 
 
 

 
 


