
 
 
  
 

 

10 - 2017 

DLCPM Enterprise 2018 
Inventory 

Management 
User Guide 

 

 

DLCPM Enterprise 2018 



 
 

Inventory Management 
http://MagicTouchSoftware.com 

 

Contents 
What is DLCPM Inventory? ........................................................................................................................... 1 

Inventory Setup ............................................................................................................................................. 2 

Item Categories ......................................................................................................................................... 2 

Item Types ................................................................................................................................................. 2 

Inventory Items ......................................................................................................................................... 3 

Reorder Point and Safety Stock for Inventory Item .................................................................................. 4 

Adjustment Reasons ................................................................................................................................. 7 

Units of Measure....................................................................................................................................... 7 

Manufacturers .......................................................................................................................................... 7 

Vendors & Purchase Orders .......................................................................................................................... 8 

Vendors ..................................................................................................................................................... 8 

Inventory Item Receipt ............................................................................................................................. 9 

Items To Order ........................................................................................................................................ 10 

Purchase Orders ...................................................................................................................................... 11 

Receive Purchase Order ...................................................................................................................... 12 

Inventory Maintenance........................................................................................................................... 13 

Inventory Adjustments ........................................................................................................................... 13 

Inventory Check Out ............................................................................................................................... 15 

Reducing Inventory on Invoicing ............................................................................................................. 16 

Inventory Depletion ................................................................................................................................ 17 

 

  



 

Inventory Management 
http://MagicTouchSoftware.com 

 

What is DLCPM Inventory? 
 

DLCPM Inventory is designed to track consumables (materials such as powder) and items or 
products sold which are not part of the manufacturing process (for example, an implant screw). 
The inventory system utilizes the two existing parts of DLCPM, namely Material and Products to 
build the inventory items. The inventory items are depleted in two ways:  

1. If an inventory item is defined as a product, the inventory quantity is reduced nightly when 
the automation job runs based on products entered on invoiced cases.   

2. A technician can check out an item defined as a material or consumable. 

The DLCPM Inventory system also includes definitions for Vendors and Purchase Orders (PO). 
Labs may create a purchase order with desired Vendors and receive the PO to update their 
inventory count. The PO requests may be sent automatically to the Vendor as well. 

Here is a brief list of Inventory Features and Functions: 

 Create list of Vendors 
 Create inventory item list from existing Materials or Products 
 Assign preferred Vendor for each Inventory item 
 Generate and Receive Purchase Order(s) 
 Email Purchase Order to Vendor manually or automatically each night 
 Inventory Checkout for Technicians 
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Inventory Setup  
(File > Global Settings > Inventory) 

This section of the Global Settings is where you will configure all of the maintenance lists for 
Inventory. Each section must be completed with the appropriate selections and definitions.  

 

 

Item Categories  

(File > Global Settings > Item Categories) 

The item categories can be used to group and organize the entries in your inventory items list.  

Item Types  

(File > Global Settings > Item Types) 

In addition to the item category definition, it is also important to define an organized list of item types.  

Please note: Both of the category and type definitions on inventory items are designed solely for lab 
organization and do not have a direct impact on the behavior of the inventory system. 
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Inventory Items  

(File > Global Settings > Inventory Items) 

An Inventory Item could be either a Product or Material.  A product could be something that you sell, 
such as a Milling Block.  A material would be an item that is used in making a product, such as gold or 
porcelain powder. All of the items defined in the item maintenance is what you will be able to keep 
record of by depleting or adjusting inventory amounts.  
 
On this form there is also a tab called Transactions Log, which will log all activity for the selected 
inventory item. Each log will list the type of transaction, timestamp and if the inventory was increased or 
decreased. If an inventory item was checked out, a log will list on this tab as well.  
 

 

 

 

  



 

Inventory Management 
http://MagicTouchSoftware.com 

Reorder Point and Safety Stock for Inventory Item  

(File > Global Settings > Inventory Items > Add/Edit Inventory Item) 

When adding or editing inventory items in the inventory item maintenance list, it is important to 
configure all definitions and properties on the inventory item.  

In the Vendor section, you can define both the Reorder Point and Safety Stock amounts.   

 

The reorder point field is used to define the quantity of when you will need to reorder that inventory 
item. Additionally, located in the Inventory section of the Global Settings is a checkbox option which you 
can set if you would like to automatically generate a Purchase Order when the item quantity has 
reached the set reorder point.  

The Safety Stock is a similar feature but is primarily used to alert users when an inventory item is 
running low. When the inventory item reaches the defined safety stock quantity, an alert will populate 
notifying the user that this item has reached or is below the set safety stock. 

Please note: the reorder point must be equal to or less than the set safety stock.  
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In the Inventory Section of the Global Settings, there is a checkbox option and drop down menu to select 
for which users will be notified when the item is below the safety stock or reorder point. 

 

The groups listed in this drop down menu are groups defined and configured in the System Admin 
Program. Users that are a member of the selected group will receive the following alert epop message: 
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In order for these notifications to populate, the job located in the Job Management called Generate Low 
Stock Inventory Notification must be active. 
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Adjustment Reasons  

(File > Global Settings > Adjustment Reasons) 

If there are any manual adjustments that need to be made to inventory items, it is required to select a 
reason when adding an adjustment. On adjustments, you are able to increase or decrease the quantity 
of specific items.  

Units of Measure  

(File > Global Settings > Units of Measure) 

For each inventory item that is defined in the items maintenance, you are able to set a unit of measure 
type. The list you define in the maintenance list for units of measure is what users will have to select 
from.  

Manufacturers  

(File > Global Settings > Manufacturers) 

On each inventory item that is defined in the items maintenance list, you are able to keep record of 
manufacturer of that item, if applicable. The list you define in the manufacturers maintenance list is 
what users will have to select from.  
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Vendors & Purchase Orders  
(Tools > Inventory Management) 

 

 

Vendors  

(Tools > Inventory Management > Vendors) 

In the Vendors section of the Inventory Management menu is where you will define the Vendors which 
inventory items are ordered from. From the Vendors menu, you are able to add new vendors, or edit 
and remove an existing vendor. Within each selected vendor, you are able to generate Purchase Orders, 
Item Receipts and Inventory items to order.   
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Inventory Item Receipt  

(Tools > Inventory Management > Vendors > Inventory Item Receipt) 

The inventory item receipt tab allows for you to record inventory items under a specified vendor 
without reference to a purchase order.  
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Items To Order  

(Tools > Inventory Management > Vendors > Items To Order) 

The inventory items that are close to the reorder or safety stock quantity will display on the items to 
order tab. This will allow users to select the option to reorder those items.  
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Purchase Orders  

(Tools > Inventory Management > Purchase Orders) 

The Purchase Orders module is used to manage all inventory purchase orders.  When adding a purchase 
order, the purchase order number will automatically generate once the purchase order has been saved.   

From this form, users may select to receive or print a purchase order. 

Please note: Users are also able to Add, Receive, Edit, Remove, or Print Purchase Orders from the 
Vendors module as well. 
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Receive Purchase Order  
(Tools > Inventory Management > Purchase Orders > Receive PO(s)) 

In order to keep record of and mark a purchase as received from the vendor, you will select the option 
for Receive PO(s) from the toolbar. This will change the highlighted purchase order’s status from 
Pending to Received.  Multiple Purchase Orders may be received by using Shift+Click. 
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Inventory Maintenance  

(Tools > Inventory Management > Maintenance) 

 

Inventory Adjustments  

(Tools > Inventory Management > Maintenance > Inventory Adjustments) 

To manually adjust inventory levels, you will use the Inventory Adjustments tab found in the Inventory 
Maintenance module. 
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From this tab you can select to Add an adjustment and from the adjustment form it is important to 
select a reason for the adjustment and capture any notes related to this adjustment.  

 

Within the add adjustments form, you will select to add an item and it is important to enter a lot 
number (if applicable) and select whether this adjustment will increase or decrease quantity of that 
item.  
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Inventory Check Out  

(Tools > Inventory Management > Maintenance > Inventory Check Out) 

When a technician uses items defined in inventory, the check out feature should be created to reflect 
the depletion of inventory. On each inventory item added into the item maintenance, the option for 
‘Reduce Quantity on Check out’ must be checked in order to reduce the inventory on the item during 
check out. 

Inventory Check Out logs are created from the Inventory Check Out tab within the Inventory 
Maintenance module. 

Please note: In order for an inventory item to reduce using the check out feature, the property for 
‘Reduce Quantity on Check Out’ must be set. 
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Reducing Inventory on Invoicing 

In addition to the adjustment and check out options, inventory can also deplete when cases are 
invoiced. On each inventory item added into the Item maintenance, the option for ‘Reduce Quantity on 
Invoice’ will reduce inventory for those products or materials that are on invoiced case. 
 
When a product or material that is defined as an inventory item is entered on an invoiced case, the 
inventory for those items will reduce when the nightly automation job is run.  

 
 
Please note: If users select to un-invoice a case with inventory items, this will not affect the inventory 
quantity for those items. 
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Inventory Depletion  

(Automated Services > Job Management) 

In the job management, there is an automated job called Inventory Depletion for Invoiced 
Cases. The schedule tab is where you will configure the frequency and other settings for the job 
to run.  

By default, the job is set to run every day at 10:00 PM at the laboratories local time. The ‘Start 
Job On’ date should be set and the job will need to be marked as Active to follow this 
frequency.  
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Please Note: This job is designed to reduce inventory for invoiced cases each day and should be 
scheduled to run before midnight each day.  The Inventory Depletion for Invoice Cases job 
should not be scheduled to run during the day.  

 


